reset customer-specific config is not possible

XMLWordPrintable

      Problem

      Wenn a customer-specific value is it can not be reset any more. So if the default set is empty (e.g. runtimeOptions.lengthRestriction.maxNumberOfLines) and this value is set for a certain customer, this setting can not be removed.
      The following error is thrown

      Your data could not be saved, on saving there was a conflict on server side!
      Server Message: Configuration value invalid: not a valid integer ''
      

      addition to that

      the above value can be set to a negativ integer like -3 which makes absolutely no sens here.

      Solution

      Add a button "EN: Remove client specific config - system default will be used again" / DE: Kundenspezifische Konfiguration löschen – Systemstandard wird wieder verwendet".

      Show this button only for configs, that are overwritten on client-level.

            Assignee:
            Sanya Mikhliaiev
            Reporter:
            Stephan Bergmann
            None
            None
            Aleksandar Mitrev
            None
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

              Created:
              Updated:
              Resolved:
              None
              None